This has been tested to work on Mikrotik 7.1.1

/ip route
add dst-address=8.8.8.8/32 gateway=10.0.1.1 scope=11 target-scope=10 comment="Validate Primary"
add gateway=8.8.8.8 distance=1 scope=30 target-scope=11 check-gateway=ping comment=Primary
add gateway=10.0.2.1 distance=2 comment=Secondary


"Destination unreachable" is ICMP type 3.

/ip firewall filter add protocol=icmp icmp-options=3 chain=forward action=drop
/ip firewall filter add action=drop chain=input icmp-options=3 protocol=icmp
/ip firewall filter add action=drop chain=output icmp-options=3 protocol=icmp

should prevent any such ICMP packets from being forwarded through the router.
If you want to prevent RouterOS itself from generating such messages dropping them in the output chain should do the trick.

-Mimbach 20220131/ 2020102501 / 2021092501